Wild Dog Adventure Riding

Technical Section => Make / Model Specific Discussions => KTM LC4 400/610/640 & 690 => Topic started by: sting on October 17, 2012, 04:52:58 pm

Title: Replacement indicators
Post by: sting on October 17, 2012, 04:52:58 pm
I'm tired of the standard indicators on my 690 breaking off, the rubber parts even vibrate off after a while. I ride around with duct tape on the indicators on a brand new bike. what replacements would anyone suggest or what solutions are out there?
Title: Re: Replacement indicators
Post by: arries on October 19, 2012, 10:44:02 am
Hi Sting

I had the same problem, the rear indicators broke off after a week. I replaced them with the 990 indicators. The fitting and electrical connections are the same as for the 690. So far they have lasted.
Title: Re: Replacement indicators
Post by: Dwerg on October 19, 2012, 10:50:08 am
Had the same on my 640. Fit flush mount indicators.

Example: http://www.ebay.co.uk/itm/TNT-Tear-Drop-Flush-Mount-Indicators-KTM-LC4-690-640-/190671348975
Title: Re: Replacement indicators
Post by: SpeedMetal on November 24, 2012, 05:33:24 pm
I fitted those to my 690 and found that they don't pull enough current which means they start to flick a lot quicker. I bought mine for R100 from startling in Edenvale. Did anyone else experience the same problem?
Title: Re: Replacement indicators
Post by: NielGS on December 31, 2012, 08:31:52 am
I fitted these...

Got them at Full Thottle Cresta. I broke off 4 sets of lights before I did this mod. It works very well!