Wild Dog Adventure Riding

Technical Section => Make / Model Specific Discussions => KTM LC4 400/610/640 & 690 => Topic started by: Amsterdam on September 01, 2015, 07:39:09 pm

Title: 690 fuse #5 keeps blowing
Post by: Amsterdam on September 01, 2015, 07:39:09 pm
OK, it is probably a pinched wire somewhere but maybe one of you knows something else that may be the problem.  The fuse that operates the horn, indicator and brake lights keeps blowing.  Initially, after replacing it still functioned a while but now it shorts out right away.  Anyone has any suggestions/experience with this?  Found another thread on this forum that was, surprise surprise, a pinched wire.
Title: Re: 690 fuse #5 keeps blowing
Post by: pietas on September 01, 2015, 07:55:52 pm
Get a wiring diagram and try and follow wires that are connected to the fuse.
Buy electronic switch cleaner and clean switches, connectors, etc.
Check that all the wires are not pinched, broken, and in good condition.

Good luck
Title: Re: 690 fuse #5 keeps blowing
Post by: 777 on September 01, 2015, 07:58:43 pm
Get a wiring diagram and try and follow wires that are connected to the fuse.
Buy electronic switch cleaner and clean switches, connectors, etc.
Check that all the wires are not pinched, broken, and in good condition.

Good luck
Google 690 Wire diagram, you will find it
Title: Re: 690 fuse #5 keeps blowing
Post by: boland on September 01, 2015, 08:34:08 pm
OK, it is probably a pinched wire somewhere but maybe one of you knows something else that may be the problem.  The fuse that operates the horn, indicator and brake lights keeps blowing.  Initially, after replacing it still functioned a while but now it shorts out right away.  Anyone has any suggestions/experience with this?  Found another thread on this forum that was, surprise surprise, a pinched wire.
Happened to me when i put new indicators on the back. I pinched the wires for the one indicator with the rear fender. They touched and blew the fuse

Hope you find it!
Title: Re: 690 fuse #5 keeps blowing
Post by: Amsterdam on September 01, 2015, 09:32:16 pm
Thanks guys.  I have the wiring diagram.  Now just have to keep tracing it until I find it.  I do have different indicators on the back, maybe that is where the problem is.  It will be a good place to start.
Title: Re: 690 fuse #5 keeps blowing
Post by: Amsterdam on September 03, 2015, 03:49:40 pm
Happened to me when i put new indicators on the back. I pinched the wires for the one indicator with the rear fender. They touched and blew the fuse

Hope you find it!

And it was the same here.  One of the wires was pinched between the grab handle/luggage rack bolts and the fender.  All fixed again.  Thanks all for the input.
Title: Re: 690 fuse #5 keeps blowing
Post by: boland on September 03, 2015, 07:15:05 pm
Happened to me when i put new indicators on the back. I pinched the wires for the one indicator with the rear fender. They touched and blew the fuse

Hope you find it!

And it was the same here.  One of the wires was pinched between the grab handle/luggage rack bolts and the fender.  All fixed again.  Thanks all for the input.

Glad you found it. Exactly where mine pinched aswell!
Title: Re: 690 fuse #5 keeps blowing
Post by: pietas on September 03, 2015, 07:26:16 pm
Mooi