Wild Dog Adventure Riding

Technical Section => Make / Model Specific Discussions => KTM LC4 400/610/640 & 690 => Topic started by: isiTututu on June 16, 2017, 03:04:56 pm

Title: 690 Battery not charging
Post by: isiTututu on June 16, 2017, 03:04:56 pm
The battery on my 690 is not charging (on the bike while riding).

It is a new battery, and comes up to full charge on an external charger. I've checked the terminals and the fuses. The bike starts easily and runs almost fine until the battery is flat, and then obviously there's nothing to drive the pumps and ECU, so it farts and pops and then stops, and that's that.

Any ideas? Regulator? Stator? Where should I start looking? I've just bought this bike, and I'm keen to understand it's quirks, but I think this is a little more than just a quirk.
Title: Re: 690 Battery not charging
Post by: Pistonpete on June 16, 2017, 05:25:21 pm
No upfront history from previous owner?
Title: Re: 690 Battery not charging
Post by: isiTututu on June 16, 2017, 05:55:23 pm
No upfront history from previous owner?

It's apparently a new/unknown problem. I'm not disputing that.  Previous owner has offered to cover the cost of repairs by the agent, but I was hoping someone could point me towards the likely cause.

I'm always keen to try to fix things myself first, as it improves my knowledge of the beast, and therefore also my chances of fixing things when I break down in the middle of nowhere.
Title: Re: 690 Battery not charging
Post by: Dux on June 16, 2017, 06:05:00 pm
Bring it around tomorrow , I can run tests for you
Title: Re: 690 Battery not charging
Post by: isiTututu on June 16, 2017, 06:24:16 pm
Bring it around tomorrow , I can run tests for you

Thank you Dux!  I've got a couple of things on the go tomorrow, and I don't think the battery will last long enough to get me from town to you. And I don't have a trailer, and the bike isn't licensed, and...  but thank you!   :thumleft:
Title: Re: 690 Battery not charging
Post by: Bill the Bong on June 17, 2017, 07:58:15 pm
There are 2 fuses (30A) underneath the main relay.  If one pops, it wont charge.  Check before worrying about rectifiers, etc.
Title: Re: 690 Battery not charging
Post by: isiTututu on June 17, 2017, 10:29:19 pm
There are 2 fuses (30A) underneath the main relay.  If one pops, it wont charge.  Check before worrying about rectifiers, etc.

Yup, I've checked that. One is the main fuse (if it blows, nothing works, incl. pump and ECU). The other is a spare.

Voltage from the stator is 24V AC on idle. Connectors between there and the regulator are good, so I reckon the regulator itself is dud.
Title: Re: 690 Battery not charging
Post by: Bill the Bong on June 19, 2017, 09:25:36 am
My regulator also failed, gave me very high voltages.  I fitted a SHINDENGEN MOSFET Fh020AA RR afterwards.  That gave very stable voltages all the way from idle to max.  Also ran dramatically cooler. 
Title: Re: 690 Battery not charging
Post by: isiTututu on June 20, 2017, 10:47:36 am
My regulator also failed, gave me very high voltages.  I fitted a SHINDENGEN MOSFET Fh020AA RR afterwards.  That gave very stable voltages all the way from idle to max.  Also ran dramatically cooler.

Where did you buy such a thing, Bill?
Title: Re: 690 Battery not charging
Post by: Bill the Bong on June 20, 2017, 11:44:20 am
I bought from eBay: http://www.ebay.com/itm/YAMAHA-SHINDENGEN-FH020AA-REGULATOR-W-CONNECTORS-REPLACES-FH012AA/380705241034?_trksid=p2047675.c100005.m1851&_trkparms=aid%3D222007%26algo%3DSIM.MBE%26ao%3D2%26asc%3D44730%26meid%3D98e14aad42a242eca9c1d3f2af2a0cb1%26pid%3D100005%26rk%3D3%26rkt%3D6%26mehot%3Dpp%26sd%3D380704480069


Be careful of the Chinese copies, some could be suspect.  The one above is a genuine unit.  The fakes could be had for R500 -600.   I've bought a spare, but I'd like to keep it.  If its an emergency, we can talk.
Title: Re: 690 Battery not charging
Post by: isiTututu on June 20, 2017, 12:25:04 pm
I bought from eBay: http://www.ebay.com/itm/YAMAHA-SHINDENGEN-FH020AA-REGULATOR-W-CONNECTORS-REPLACES-FH012AA/380705241034?_trksid=p2047675.c100005.m1851&_trkparms=aid%3D222007%26algo%3DSIM.MBE%26ao%3D2%26asc%3D44730%26meid%3D98e14aad42a242eca9c1d3f2af2a0cb1%26pid%3D100005%26rk%3D3%26rkt%3D6%26mehot%3Dpp%26sd%3D380704480069


Be careful of the Chinese copies, some could be suspect.  The one above is a genuine unit.  The fakes could be had for R500 -600.   I've bought a spare, but I'd like to keep it.  If its an emergency, we can talk.

Thanks Bill  :thumleft:
Title: Re: 690 Battery not charging and other electrical issues
Post by: isiTututu on June 22, 2017, 09:25:31 am
So yesterday, I took this bike thing to Paardeneiland to get it fixed, and as I was pulling into the parking area, I looked down at the speedo. I was doing 348km/h. I guess I must have broken the land speed record on Marine Drive then. Did anyone hear the sonic boom? Oh, and I also managed to clock up over 1000km in the 10 minutes it took me to get from home to Paardeneiland.

Anyone seen this before?
Title: Re: 690 Battery not charging
Post by: Bill the Bong on June 22, 2017, 09:37:01 am
I've heard about it.  Normally a loose frame earth.  That could explain the charging as well.
Title: Re: 690 Battery not charging
Post by: isiTututu on June 22, 2017, 09:41:48 am
I've heard about it.  Normally a loose frame earth.  That could explain the charging as well.

Hopefully!  I'll keep you posted.
Title: Re: 690 Battery not charging
Post by: MaxThePanda on June 22, 2017, 10:22:27 am
Justin's 500 got stranded on the Postal Route and we were all thinking FI or pump issues. Turned out to be a cracked earth wire/connector. If your earth connection is solid, inspect the wires closely - could be the same thing.
Title: Re: 690 Battery not charging and other electrical issues
Post by: ChrisL - DUSTRIDERS on June 22, 2017, 11:16:50 am
So yesterday, I took this bike thing to Paardeneiland to get it fixed, and as I was pulling into the parking area, I looked down at the speedo. I was doing 348km/h. I guess I must have broken the land speed record on Marine Drive then. Did anyone hear the sonic boom? Oh, and I also managed to clock up over 1000km in the 10 minutes it took me to get from home to Paardeneiland.

Anyone seen this before?
Jinne Gavin that 690 is "lewensgevaarlik"!!! :eek7: :lol8: ;)
Title: Re: 690 Battery not charging
Post by: Colin Kaapschehoop on June 27, 2017, 11:36:15 pm
Interested to hear if the charging issue was sorted & what was wrong?