Wild Dog Adventure Riding

Technical Section => Make / Model Specific Discussions => KTM LC4 400/610/640 & 690 => Topic started by: Gee S on January 28, 2020, 12:49:06 pm

Title: 690 Not Starting
Post by: Gee S on January 28, 2020, 12:49:06 pm
A few weeks ago I returned from a ride and as I pulled into the driveway the engine stalled and just would not start again.
It would crank and at times sounds like it is on the point of starting but it just does not, It would sometimes give a loud back fire

I have checked the following,
- Spark plug and spark is good,
- Loosened and cleaned all the ground cables I could find
- Checked the valve clearance and all within spec
- Fuel pump is good and have done less than Km
- Pulled the injector and the spray pattern looks ok to my inexperienced eye

I don't know what else to check so any advice or suggestions will be appreciated

Injector face
(https://i.imgur.com/EXkC7Jg.jpg)

Does this spray pattern look OK?
https://i.imgur.com/UazInNu.mp4

Egine cranking
https://i.imgur.com/w6ZEQDb.mp4




Title: Re: 690 Not Starting
Post by: Manic on January 28, 2020, 01:18:02 pm
Sterkte  :thumleft:

http://www.wilddog.za.net/forum/index.php?topic=237303.0
Title: Re: 690 Not Starting
Post by: Rascal on January 28, 2020, 01:35:53 pm
Skroeg die elbow op die injector housing af. daar is n klein wit fuel filter in die housing waar die fuel line vasmaak. haal hom uit en kyk of hy vuil is. probeer start sonder die filter en vervang met nuwe een.
Title: Re: 690 Not Starting
Post by: Gee S on January 28, 2020, 02:16:52 pm
Skroeg die elbow op die injector housing af. daar is n klein wit fuel filter in die housing waar die fuel line vasmaak. haal hom uit en kyk of hy vuil is. probeer start sonder die filter en vervang met nuwe een.
Will check the filter but have done the reverse flow on the injector onto a white cloth and no dirt or debris came out.
Title: Re: 690 Not Starting
Post by: BiG DoM on January 28, 2020, 02:23:04 pm
The filter is before the injector - normally in a quick disconnect fitting (well on the 701 anyway). What was your in tank filter like when you did the fuel pump? Does your bike have a sidestand switch connected?
Title: Re: 690 Not Starting
Post by: Gee S on January 29, 2020, 08:42:41 am
The filter is before the injector - normally in a quick disconnect fitting (well on the 701 anyway). What was your in tank filter like when you did the fuel pump? Does your bike have a sidestand switch connected?

The old filter did not look very bad. I also have an additional filter between the front and rear tank.
Side stand switch is bypassed but that is something I have not checked, will remove the bypass plug tonight and see if that makes a difference.
Is there a way to bypass the tilt sensor?

Title: Re: 690 Not Starting
Post by: BiG DoM on January 29, 2020, 08:47:52 am
The filter is before the injector - normally in a quick disconnect fitting (well on the 701 anyway). What was your in tank filter like when you did the fuel pump? Does your bike have a sidestand switch connected?


Is there a way to bypass the tilt sensor?

Ask Taye Perry  >:D
Title: Re: 690 Not Starting
Post by: ClimbingTurtle on January 29, 2020, 08:58:49 am
The filter is before the injector - normally in a quick disconnect fitting (well on the 701 anyway). What was your in tank filter like when you did the fuel pump? Does your bike have a sidestand switch connected?


Is there a way to bypass the tilt sensor?

Ask Taye Perry  >:D

 :imaposer:

Actually, thats not funny.....
Title: Re: 690 Not Starting
Post by: sidetrack on January 30, 2020, 04:04:02 pm
Backfire could be timing issue, unlikely but any chance the timing chain could have jumped a tooth ? Everything still line up when you checked the valves ?
Title: Re: 690 Not Starting
Post by: Gee S on February 03, 2020, 03:10:19 pm
Backfire could be timing issue, unlikely but any chance the timing chain could have jumped a tooth ? Everything still line up when you checked the valves ?

Everything lines up.
I have a side stand switch eliminator fitted and reconnected the switch to make sure that the eliminator works but no difference.
I am now busy to remove and clean every single connector I can find on the bike.
Title: Re: 690 Not Starting
Post by: Operator on February 03, 2020, 03:36:49 pm
Gee S

PM me your number....................I have an idea

Or phone me on my cell 0836539600
Title: Re: 690 Not Starting
Post by: Manic on February 03, 2020, 07:19:03 pm
Gee S

PM me your number....................I have an idea

Or phone me on my cell 0836539600

Blitz and lighter?
Title: Re: 690 Not Starting
Post by: zacapa on February 03, 2020, 07:55:19 pm
Bushcat on the forum here may have some ideas. He dealt with similar issues for about a year until it was resolved. Let me not get started on my 690 riding mates...
Title: Re: 690 Not Starting
Post by: Archangel on March 10, 2020, 09:56:06 am
Sorted yet?

Ek weet ongelukkig nou baie meer van hierdie bikes as wat ek ooit wou.  :imaposer:  Happy om te help waar ek kan...  :thumleft:
Title: Re: 690 Not Starting
Post by: geopat on March 10, 2020, 10:16:00 am
spray pattern may look fine to your eye but thats not to say it is fine try to attach the injector backwards and give it a few turns then re install and try again worked for me after I also thought mine was fine
Title: Re: 690 Not Starting
Post by: adamktm on December 02, 2020, 05:09:08 pm
Gee S

PM me your number....................I have an idea

Or phone me on my cell 0836539600

Hi

My mate has the same issue with his. What was you idea @Operator and did it sort it @Gee S ?
Title: Re: 690 Not Starting
Post by: Operator on December 03, 2020, 04:51:32 pm
Adam phone me
Title: Re: 690 Not Starting
Post by: adamktm on December 05, 2020, 11:47:57 am
I donít know your phone number  :deal:
Title: Re: 690 Not Starting
Post by: Baches on December 08, 2020, 04:38:33 pm
Did you find out what was wrong ?
Title: Re: 690 Not Starting
Post by: adamktm on December 09, 2020, 03:49:51 pm
Not yet, bike is going to KTM tomorrow.
Title: Re: 690 Not Starting
Post by: BiG DoM on December 09, 2020, 07:15:45 pm
My money would still be on fuel filters/pump or injector  :o
Title: Re: 690 Not Starting
Post by: adamktm on December 10, 2020, 07:00:40 pm
My money is on the same. Fuel pump first in line. 2010 with 30k on the clock
Title: Re: 690 Not Starting
Post by: adamktm on December 15, 2020, 09:00:19 am
The problem was a dirty injector
Title: Re: 690 Not Starting
Post by: BiG DoM on December 15, 2020, 09:27:28 am
The problem was a dirty injector

There you go! Happy it is sorted.  :thumleft:

PS: fit an external inline filter like this or similar
Title: Re: 690 Not Starting
Post by: geopat on December 15, 2020, 11:22:30 am
spray pattern may look fine to your eye but thats not to say it is fine try to attach the injector backwards and give it a few turns then re install and try again worked for me after I also thought mine was fine

Called it hahaha I had the same shit was stuck in Kamnajab for a week
Title: Re: 690 Not Starting
Post by: adamktm on December 15, 2020, 04:17:44 pm
Where can I buy a Golan here in SA Big Dom?
Title: Re: 690 Not Starting
Post by: BiG DoM on December 15, 2020, 04:53:36 pm
Where can I buy a Golan here in SA Big Dom?

I ordered mine in off eBay but Wessel from LoCoMoTo is looking into it as we speak.  :thumleft:
Title: Re: 690 Not Starting
Post by: geopat on December 15, 2020, 04:59:42 pm
Strangely enough my issue happened on the first trip after I fitted a Golan, I have since taken it out and use the stock but I check it regularly and carry a spare. You can have mine for free if you like
Title: Re: 690 Not Starting
Post by: BiG DoM on December 15, 2020, 07:19:19 pm
Strangely enough my issue happened on the first trip after I fitted a Golan, I have since taken it out and use the stock but I check it regularly and carry a spare. You can have mine for free if you like

What was your issue? I doubt it have anything to do with the Golan filter. Did you remove the in-tank filter? When you say use the stock is it the stock in tank or the stock filter in the QD? Many have done this mod on 701's with success and Slavens Racing, Rally Raid, Zipty and many others sell the Golan - in fact it is sold with an integrated QD fitting so it is plug and play.
Title: Re: 690 Not Starting
Post by: adamktm on December 15, 2020, 07:34:39 pm
Strangely enough my issue happened on the first trip after I fitted a Golan, I have since taken it out and use the stock but I check it regularly and carry a spare. You can have mine for free if you like

Thanks mate, have sent you a PM
Title: Re: 690 Not Starting
Post by: adamktm on December 15, 2020, 07:36:02 pm
Strangely enough my issue happened on the first trip after I fitted a Golan, I have since taken it out and use the stock but I check it regularly and carry a spare. You can have mine for free if you like

What was your issue? I doubt it have anything to do with the Golan filter. Did you remove the in-tank filter? When you say use the stock is it the stock in tank or the stock filter in the QD? Many have done this mod on 701's with success and Slavens Racing, Rally Raid, Zipty and many others sell the Golan - in fact it is sold with an integrated QD fitting so it is plug and play.

What is a QD? 😂
Title: Re: 690 Not Starting
Post by: BiG DoM on December 15, 2020, 08:31:47 pm
Strangely enough my issue happened on the first trip after I fitted a Golan, I have since taken it out and use the stock but I check it regularly and carry a spare. You can have mine for free if you like

What was your issue? I doubt it have anything to do with the Golan filter. Did you remove the in-tank filter? When you say use the stock is it the stock in tank or the stock filter in the QD? Many have done this mod on 701's with success and Slavens Racing, Rally Raid, Zipty and many others sell the Golan - in fact it is sold with an integrated QD fitting so it is plug and play.

What is a QD? 😂

Quick Disconnect (fuel line fitting)
Title: Re: 690 Not Starting
Post by: geopat on December 15, 2020, 11:23:31 pm
Strangely enough my issue happened on the first trip after I fitted a Golan, I have since taken it out and use the stock but I check it regularly and carry a spare. You can have mine for free if you like

What was your issue? I doubt it have anything to do with the Golan filter. Did you remove the in-tank filter? When you say use the stock is it the stock in tank or the stock filter in the QD? Many have done this mod on 701's with success and Slavens Racing, Rally Raid, Zipty and many others sell the Golan - in fact it is sold with an integrated QD fitting so it is plug and play.

I did 50 000km no my bike with no fueling issues I fitted a golan filter from rally raid and got stuck with a partially blocked injector 4000 km into a cape town-kaokoland trip mine was installed next to the airbox (I removed the QD from the tank and used the hose clamps as my filter had no QD and I removed the OEM filter)  There are always lots of variables in these situations but for me just looking at the filter I cant see it being as efficient as the OEM, the surface area is greatly reduced and the action of cleaning the filter creates a massive opportunity for shit to get into your lines,  for me personally I prefer to use stock  and be conscious that its a maintenance item and if I was going to make it more bullet proof I would fit a T piece in the tank  and run 2 OEM filters  in parallel, if your hose clamps are bullet proof I cant see a better option than this 
Title: Re: 690 Not Starting
Post by: BiG DoM on December 16, 2020, 07:15:47 am
And every time you want to service the filter if it has not already blocked unseen and shagged your pump by overworking it you have to lift the tank - no thanks. The Golan 5Ē of filtering area combined with Gulgla filler filters works for me. But ja each to their own.