Wild Dog Adventure Riding

Technical Section => Make / Model Specific Discussions => Husqvarna => Topic started by: Jayson on November 18, 2020, 10:35:59 am

Title: 501 kill switch kaput
Post by: Jayson on November 18, 2020, 10:35:59 am
Hi Guys
2017 501

I rode home in the rain from a  ride last weekend and then proceeded to wash my bike after and i fear one of these actions led to water getting into the kill switch/cluster as the kill switch no longer works at all. I have sprayed contact cleaner and pressured air and nothing. So i recon its a replacement, called KTM and the cluster is nearly R700 and 2-3 week waiting period...Now the cluster splits into two, the bottom half of the cluster seems to work perfectly. Any idea where i could source an alternate before i fork out for a new unit?

Many thanks
Jayson
Title: Re: 501 kill switch kaput
Post by: JacoM on November 18, 2020, 11:19:52 am
Hi, for 501,  I would deal with Eddie2Race, the Husky agents. They are in Belville.
Title: Re: 501 kill switch kaput
Post by: McKracken on November 18, 2020, 11:48:26 am
Don't be shy to open and clean up the switches yourself, they are very simple. Clean metal contacts with a small business file and you should be sorted.
Just open them slowly as there are often springs and balls that fall out.
Which switchgear do you have? Pic?

Sent from my SGP311 using Tapatalk

Title: Re: 501 kill switch kaput
Post by: BullSmit on November 18, 2020, 01:24:37 pm
+1...

Although I have an XRL, I also had issues with the kill switch.

As McKracken said, open CAREULLY because of over zealous springs and balls.

And take photos during disassembling. It is not fun trying to find how things go together although you think you will remember.

How do I know?
Title: Re: 501 kill switch kaput
Post by: Jayson on November 18, 2020, 01:28:50 pm
Hi Boys, by the time i got to the point where i was ready to open the switch up my patience was thin, so i made a mess of it and lost the small balls etc, lesson learnt.

This is the switch i have, seems common in the KTm and Husky range

Title: Re: 501 kill switch kaput
Post by: BullSmit on November 18, 2020, 01:31:37 pm
Hi Boys, by the time i got to the point where i was ready to open the switch up my patience was thin, so i made a mess of it and lost the small balls etc, lesson learnt.

This is the switch i have, seems common in the KTm and Husky range

 :biggrin: :biggrin: :biggrin:

Apologies for the laughing!

I think you can take the new one apart just to see how it works.
Title: Re: 501 kill switch kaput
Post by: McKracken on November 18, 2020, 01:41:43 pm
Dammit. Those little balls are not going to be easy to find. You obviously clicked to drill out the back of the rivets.
If you plug it in while it's open does it work?


Sent from my SGP311 using Tapatalk

Title: Re: 501 kill switch kaput
Post by: Jayson on November 18, 2020, 02:25:57 pm
Those little balls were like bullets, literally gone in seconds.....It doesn't work at all even though i can see into it now sadly, eish. The spring hit me in the face then then shot off to another world too...
Title: Re: 501 kill switch kaput
Post by: katana on November 18, 2020, 02:38:30 pm
Startline sells a reproduction.
Title: Re: 501 kill switch kaput
Post by: Jayson on November 18, 2020, 03:55:00 pm
Katana you are an absolute star, just picked up a new and identical in every way switch from Startline for R345!!!!!

Thanks again!!!!
Title: Re: 501 kill switch kaput
Post by: Jayson on November 19, 2020, 09:42:26 am
AHHHH MAN. So after installing the new kill switch that is again perfect.  This does still not kill the bike when its running so I am guessing the next option is to follow the wire harnesses and look for a pinch or break in that particular wire. Everything else works perfectly.....so odd. I am so reluctant to start taking the tape off the harnesses to find the fault. I read somewhere that the kill switch is the single wire that runs on its own off the switch. Anyone know where this cable should go to?

Thanks all
Jay
Title: Re: 501 kill switch kaput
Post by: Tman21 on November 19, 2020, 09:52:33 am
Sorry I read this so late,

Have one on the shelf at home you could have
Title: Re: 501 kill switch kaput
Post by: katana on November 19, 2020, 03:10:09 pm
There is a black/yellow wire behind the headlight.  This is the wire that feeds neg to the kill switch circuit.  It is a set of male and female push lugs.  It is the loose wire on the switch unit wiring.  If yours is the same as my 2012 exc... 
Title: Re: 501 kill switch kaput
Post by: Jayson on November 19, 2020, 04:02:28 pm
Thanks again guys!!!!

Yes i have a single white and grey wire that i understand to be the kill wire.......however mine seems to then go into the main harness and terminates who knows where...I am going to try follow it this evening and hopefully see where it terminates. According to YouTube it should ground somewhere on the frame.....I am going to try touch the frame with this wire and if it does cut the circuit then i may be able to bypass fault finding the end of the one that runs through the harness......eish :o

Title: Re: 501 kill switch kaput
Post by: Jayson on November 20, 2020, 10:49:41 am
OK, so i took the tank off last night and see no loose or cut wires at all, everything looks in tip top shape. I did give all connections a quick squirt of Q20. Will put the bike back together over the weekend and see if it was a loose or bad connection. Was very impressed at how easy it is to take the bike down to its bare bones, about 10 minutes max to remove seat, all fairings, tank, very well thought out design.
Title: Re: 501 kill switch kaput
Post by: Jayson on December 02, 2020, 03:07:50 pm
Some feedback. The good chaps at Eddy 2 Race found the kill switch wire and broken off in the wire harness under the bars. Wire repaired and as good as new. Great service from the boys there too!
Title: Re: 501 kill switch kaput
Post by: Bullet on December 03, 2020, 12:24:27 pm
I had a similar problem on my 500EXC. Intermittent at first then no kill switch. I opened the switch and tested with a multi-meter but it was fine so unplugged it and traced the earth to earth. That was ok. The other side runs through the main loom back to the CDI. I found a break in the copper core on this wire about halfway back to the CDI unit. That is the 2nd wire that I have had similar issues with.
Title: Re: 501 kill switch kaput
Post by: Jayson on December 04, 2020, 07:57:43 am
A few of the European forums suggested this is a  comman fault but I didn't have the balls to open the wiring loom up and sonnet it to the professionals.  :imaposer:
Title: Re: 501 kill switch kaput
Post by: McKracken on December 05, 2020, 06:50:01 am
Murphy's law, my 501 kill switch has started acting up.
I think I know where the problem lies, there's a bullet connector to earth which I've had issues with before..
Also I'm really not stoked with the light/indicator/hooter/kill switch cluster, and was wondering if anyone has replaced it with something else?