Welcome, Guest. Please Login or Register

Author Topic: Installing a TrailTech Striker and LED lights  (Read 4077 times)

0 Members and 1 Guest are viewing this topic.

Offline swart skaap

  • Deleted Users
  • Senior Member
  • *
  • Bike: AJS (all models)
    Location: Gauteng
  • Posts: 626
Re: Installing a TrailTech Striker and LED lights
« Reply #60 on: September 18, 2013, 01:35:27 pm »
You can't fault the Americans on service
 :thumleft:

I didn't read your elaborate post about the speedo issues  :-\
I've fault tested my units before by fabricating a pickup with a radio shack magnetic switch.

-- Jou lekke ding! --
 

Offline alanB

  • Vendors
  • Forum Whore
  • ****
  • Bike: Husqvarna (all models)
    Location: Gauteng
  • Posts: 6,769
  • Thanked: 10 times
    • www.extinction.co.za
Re: Installing a TrailTech Striker and LED lights
« Reply #61 on: September 26, 2013, 07:52:26 am »
OK after a long ride up to Vaalwater and back this last weekend, I can report that the TrailTech Striker seems to be behaving itself - finally!

Both the speedo and distance readings seem to be consistent and are not behaving erratically anymore  :thumleft:  Looks like the new speedo cable sorted the problem.

And for some reason the remote switch works all the time as well  :thumleft: :ricky:

I dont understand why the remote switch is suddenly OK now, but hey I'm not complaining.
Husqvarna '09 610TE - Great Bike!

I just finished a SciFi novel Extinction: Task Team, download the preview.