Welcome, Guest. Please Login or Register

Author Topic: 690 fuse #5 keeps blowing  (Read 1730 times)

0 Members and 1 Guest are viewing this topic.

Offline Amsterdam

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 1,291
  • Thanked: 90 times
690 fuse #5 keeps blowing
« on: September 01, 2015, 07:39:09 pm »
OK, it is probably a pinched wire somewhere but maybe one of you knows something else that may be the problem.  The fuse that operates the horn, indicator and brake lights keeps blowing.  Initially, after replacing it still functioned a while but now it shorts out right away.  Anyone has any suggestions/experience with this?  Found another thread on this forum that was, surprise surprise, a pinched wire.
KTM 500 XCW, Husqvarna 701, KTM 1190 Adventure
 

Offline pietas

  • Senior Member
  • ***
  • Bike: BMW R80GS
    Location: Western Cape
  • Posts: 1,180
  • Thanked: 20 times
  • Gryskop seuntjie
Re: 690 fuse #5 keeps blowing
« Reply #1 on: September 01, 2015, 07:55:52 pm »
Get a wiring diagram and try and follow wires that are connected to the fuse.
Buy electronic switch cleaner and clean switches, connectors, etc.
Check that all the wires are not pinched, broken, and in good condition.

Good luck
Groot berge en lang grond paaie
 

Offline 777

  • Senior Member
  • ***
  • Bike: KTM 690 Enduro
    Location: Kwazulu Natal
  • Posts: 2,447
  • Thanked: 4 times
Re: 690 fuse #5 keeps blowing
« Reply #2 on: September 01, 2015, 07:58:43 pm »
Get a wiring diagram and try and follow wires that are connected to the fuse.
Buy electronic switch cleaner and clean switches, connectors, etc.
Check that all the wires are not pinched, broken, and in good condition.

Good luck
Google 690 Wire diagram, you will find it
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, KTM 500 EXC
 

Offline boland

  • Senior Member
  • ***
  • Bike: KTM 990 Adventure
    Location: Western Cape
  • Posts: 1,061
  • Thanked: 23 times
Re: 690 fuse #5 keeps blowing
« Reply #3 on: September 01, 2015, 08:34:08 pm »
OK, it is probably a pinched wire somewhere but maybe one of you knows something else that may be the problem.  The fuse that operates the horn, indicator and brake lights keeps blowing.  Initially, after replacing it still functioned a while but now it shorts out right away.  Anyone has any suggestions/experience with this?  Found another thread on this forum that was, surprise surprise, a pinched wire.
Happened to me when i put new indicators on the back. I pinched the wires for the one indicator with the rear fender. They touched and blew the fuse

Hope you find it!
« Last Edit: September 01, 2015, 08:38:45 pm by boland »
 

Offline Amsterdam

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 1,291
  • Thanked: 90 times
Re: 690 fuse #5 keeps blowing
« Reply #4 on: September 01, 2015, 09:32:16 pm »
Thanks guys.  I have the wiring diagram.  Now just have to keep tracing it until I find it.  I do have different indicators on the back, maybe that is where the problem is.  It will be a good place to start.
KTM 500 XCW, Husqvarna 701, KTM 1190 Adventure
 

Offline Amsterdam

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 1,291
  • Thanked: 90 times
Re: 690 fuse #5 keeps blowing
« Reply #5 on: September 03, 2015, 03:49:40 pm »
Happened to me when i put new indicators on the back. I pinched the wires for the one indicator with the rear fender. They touched and blew the fuse

Hope you find it!

And it was the same here.  One of the wires was pinched between the grab handle/luggage rack bolts and the fender.  All fixed again.  Thanks all for the input.
KTM 500 XCW, Husqvarna 701, KTM 1190 Adventure
 

Offline boland

  • Senior Member
  • ***
  • Bike: KTM 990 Adventure
    Location: Western Cape
  • Posts: 1,061
  • Thanked: 23 times
Re: 690 fuse #5 keeps blowing
« Reply #6 on: September 03, 2015, 07:15:05 pm »
Happened to me when i put new indicators on the back. I pinched the wires for the one indicator with the rear fender. They touched and blew the fuse

Hope you find it!

And it was the same here.  One of the wires was pinched between the grab handle/luggage rack bolts and the fender.  All fixed again.  Thanks all for the input.

Glad you found it. Exactly where mine pinched aswell!
 

Offline pietas

  • Senior Member
  • ***
  • Bike: BMW R80GS
    Location: Western Cape
  • Posts: 1,180
  • Thanked: 20 times
  • Gryskop seuntjie
Re: 690 fuse #5 keeps blowing
« Reply #7 on: September 03, 2015, 07:26:16 pm »
Mooi
Groot berge en lang grond paaie