Welcome, Guest. Please Login or Register

Author Topic: 690 in limp mode ...  (Read 2099 times)

0 Members and 1 Guest are viewing this topic.

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
690 in limp mode ...
« on: May 16, 2016, 02:50:30 pm »
Hi All
Would just like to k now if anyone here have experienced this issue ,it is a 2012 690 SE.
Couple of days ago FI light just randomly came on while riding ,did not blink when in neutral just stayed on constantly. After bike was switched off and back on the light did not come back on ,it still pulled like normal though while the light was on. This morning on my way to work the bike just lost power all of a sudden and then just started spluttering and won`t rev above 4k revs without it spluttering and bogging ,although the FI light is not on. Tried switching the bike off and letting it stand for a while and then switched it back on but problem still there.
Please does anyone have any ideas ,phoned the KTM dealer and they reckon i should disconnect the battery and leave it for half an hour and then try again. :-\ :'(
« Last Edit: May 17, 2016, 07:05:55 am by Kaaskrul »
 

Offline witblitz

Re: 690 SE in limp mode ...
« Reply #1 on: May 16, 2016, 04:14:16 pm »
Sounds like mine when my fuel pump went.

Fuel level?
Turn the ignition off and on a few times and listen how the pump primes. After priming a few times and it starts sounding weaker, your pump is on the way out.
 

Offline Operator

  • is a Forum Vendor and a
  • Forum Whore
  • ****
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 5,585
  • Thanked: 151 times
  • Official Vendor
    • Vendor
Re: 690 SE in limp mode ...
« Reply #2 on: May 16, 2016, 04:24:24 pm »
phoned the KTM dealer and they reckon i should disconnect the battery and leave it for half an hour and then try again. :-\ :'(

So...............did you disconnect the battery ?
 

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
Re: 690 SE in limp mode ...
« Reply #3 on: May 16, 2016, 04:30:06 pm »
Not yet ,had to limp back home and get the cage ,now i`m sitting at work and all i can think of is my sick bike at home ,will try it tonight when i get home. One sound i did notice that was different sounded like it was coming from engine when idling ,almost like it is missing a beat every now and then
 

Offline adv

  • <INSERT CUSTOM TITLE HERE>
  • Forum Whore
  • ****
  • Bike: Honda XR650R
    Location: Western Cape
  • Posts: 6,667
  • Thanked: 7 times
  • Wheelie Everything.
    • Clutch Up
Re: 690 SE in limp mode ...
« Reply #4 on: May 16, 2016, 05:38:24 pm »
wow, 690SE must be a new model.  :pot:
 

Offline 2StrokeDan

  • Castrated Dog
  • ******
  • Bike: KTM 690 Adventure
    Location: Western Cape
  • Posts: 21,561
  • Thanked: 727 times
Re: 690 SE in limp mode ...
« Reply #5 on: May 16, 2016, 07:28:52 pm »
Have you got an aftermarket [car] fuel filter fitted? Without a proper FI fuel filter you will get rubbish through to the injector.
 

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
Re: 690 SE in limp mode ...
« Reply #6 on: May 17, 2016, 06:58:23 am »
wow, 690SE must be a new model.  :pot:

Wow thanks for your valuable input , might never have solved tge issue without your help
 

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
Re: 690 in limp mode ...
« Reply #7 on: May 17, 2016, 07:09:29 am »
Disconnecting the battery didn't solve the issue
 

Offline Ganjora

Re: 690 in limp mode ...
« Reply #8 on: May 17, 2016, 07:23:04 am »
 

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
Re: 690 in limp mode ...
« Reply #9 on: May 17, 2016, 07:41:06 am »
Thanks , yeah next step is dealer then i suppose i best get some proper lube
 

Offline LONG BOB

  • Senior Member
  • ***
  • Bike: KTM 690 Adventure
    Location: Kwazulu Natal
  • Posts: 543
  • Thanked: 6 times
Re: 690 in limp mode ...
« Reply #10 on: May 20, 2016, 02:38:53 pm »
Had something similar, was the regulator. Also spluttered when you reved.
 

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
Re: 690 in limp mode ...
« Reply #11 on: June 03, 2016, 02:24:01 pm »
Eish ,so bike has been with KTM dealer for the last 3 weeks ,they got back to me today with a quote ,and no amount of vaseline would have helped for this ,13k to rebuild top end ...
Bike has 7000 km on ,surely this can`t be right ?
 

Offline Dwerg

  • Moderator
  • Bachelor Dog
  • *****
  • Bike: KTM 690 Enduro
    Location: Gauteng
  • Posts: 10,977
  • Thanked: 185 times
    • Wise Web Worx
Re: 690 in limp mode ...
« Reply #12 on: June 24, 2016, 09:43:40 am »
What happened and is the bike now ok? Have you owned the bike from new?
Current: KTM 690R
Previous: KTM 790ADV, 640ADV, 950ADV, 250XCW BMW F650GS Single, F650GS Twin, F800GS, G450X, R50/2 Honda CRF450X, CRF230 x 2, VFR400 NC30, Z50 Mini Trail Yamaha BWS100 x 2, LB80 Chappy
 

Offline SpitFireRSA

  • Newbie
  • *
  • Bike: KTM 690 Enduro
    Location: Western Cape
  • Posts: 25
Re: 690 in limp mode ...
« Reply #13 on: August 07, 2016, 10:02:32 pm »
Hi !

Sorry to hear about that one - I can relate to this.

Had the same prognosis you describe, limped it all they way to mates house, and then to E2R - I was lucky not to have anything pull through the motor, which I guess in your case as well, as that could have made things worse !

In my episode I was told " riding her to hard " caused the exhaust rocker arm to fail - but this seems to be rather common thing on the early 690's (Pre 2013), quick google search will reflect this.

I had 15K on the clock when this happened .. 2K after buying her  :-\

==

Do you have the invoice for what they quoted you on or said what the diagnosis was in the end causing it to fail ?

==

I installed a manual cam-chain tensioner and kicked my girl up a tooth in front from 15 to 16 based on recommendations if you are going to do some prolonged highway speeds (120+).

Also considering silicone hoses as this should also keep the temperature more constant - this will need to be ordered from E-bay though....
 

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
Re: 690 in limp mode ...
« Reply #14 on: January 16, 2017, 10:11:19 am »
Hi SpitfireRSA
Yeah that was exactly what caused my issues too ,exhaust rocker arm.
Eventually 18k rebuild ,have now done about 5000km since rebuild ,so far so good
 

Offline geopat

Re: 690 in limp mode ...
« Reply #15 on: January 18, 2017, 04:50:03 am »
you got off lightly while re coating my cylinder the guys found this................ faaaaaark!!!!!!!!! not going to be walking after the raping im about to recieve......
 

Offline Kaaskrul

  • Member
  • **
  • Bike: Werner (all models)
  • Posts: 89
Re: 690 in limp mode ...
« Reply #16 on: January 18, 2017, 10:51:41 am »
Ouch ! Yeah you going to be in limp mode after this ...
 

Offline SpitFireRSA

  • Newbie
  • *
  • Bike: KTM 690 Enduro
    Location: Western Cape
  • Posts: 25
Re: 690 in limp mode ...
« Reply #17 on: January 18, 2017, 11:45:22 am »
you got off lightly while re coating my cylinder the guys found this................ faaaaaark!!!!!!!!! not going to be walking after the raping im about to recieve......

Eina Pyn  :o .. How many KM's have you done ?

Goodluck !
 

Offline Dwerg

  • Moderator
  • Bachelor Dog
  • *****
  • Bike: KTM 690 Enduro
    Location: Gauteng
  • Posts: 10,977
  • Thanked: 185 times
    • Wise Web Worx
Re: 690 in limp mode ...
« Reply #18 on: January 18, 2017, 12:28:15 pm »
You guys are scaring me. My 690 has 24 000kms of solid abuse on it. I have said from day one that I just want the motor to last to 50k without major repairs. I have at least serviced it every 5k and not every 10k as prescribed
Current: KTM 690R
Previous: KTM 790ADV, 640ADV, 950ADV, 250XCW BMW F650GS Single, F650GS Twin, F800GS, G450X, R50/2 Honda CRF450X, CRF230 x 2, VFR400 NC30, Z50 Mini Trail Yamaha BWS100 x 2, LB80 Chappy
 

Offline geopat

Re: 690 in limp mode ...
« Reply #19 on: January 18, 2017, 06:58:04 pm »
You guys are scaring me. My 690 has 24 000kms of solid abuse on it. I have said from day one that I just want the motor to last to 50k without major repairs. I have at least serviced it every 5k and not every 10k as prescribed

Don't lose heart from that pic it was my own fault she ran low on oil due to worn exhaust valve stem seals that the dealer missed in the service all the reading that I've done points to the post 2013 engines being solid if you stay on top of maintenance  I will take the punishment here call it school fees and get my baby back simply because I LOVE this bike and there's not much out there I'd rather be riding

Oh and she gave me 30 000 trouble free km before the trouble started