Welcome, Guest. Please Login or Register

Author Topic: Help Please!  (Read 1167 times)

0 Members and 1 Guest are viewing this topic.

Offline BIKER

  • Member
  • **
  • Bike: KTM 690 Adventure
    Location: Western Cape
  • Posts: 61
Help Please!
« on: August 01, 2016, 01:44:40 pm »
 My 2011 690R cut out completely this weekend whilst doing +-120km/h and noticed FI light on,motor turns over but won't fire up.FI Light flashes 4 long and 6 short.

Can anyone offer some possible cause?? ???
 

Offline Blender

Re: Help Please!
« Reply #1 on: August 01, 2016, 02:34:51 pm »
I don't see the code you are referring to in the manual.  ???

The following might give you an idea!

http://www.manualslib.com/manual/90448/Ktm-690-Enduro-Eu.html?page=146
The codes are also in your user manual.  :deal:
Honda Varadero
KTM 690 Enduro R
'90 KDX200
'83 XT500 (never should've sold) :(
MBX50 (the first one!)
 

Offline BIKER

  • Member
  • **
  • Bike: KTM 690 Adventure
    Location: Western Cape
  • Posts: 61
Re: Help Please!
« Reply #2 on: August 01, 2016, 03:50:41 pm »
 :thumleft:Checked again and it is 3 Long flashes and 7 short.Ignition coil/circuit fault.

Coil F$#@ed???
 

Offline Bill the Bong

  • CRF450X for the win
  • Senior Member
  • ***
  • Bike: Cagiva Elefant 900
    Location: Northern Cape
  • Posts: 4,065
  • Thanked: 88 times
Re: Help Please!
« Reply #3 on: August 01, 2016, 09:27:48 pm »
The spade terminals are either loose where they attach to the coil or one of the wires have broken off at the connector.  Pretty common problem.
 

Offline Blender

Re: Help Please!
« Reply #4 on: August 01, 2016, 09:40:13 pm »
Yep, I would also put money on a broken wire or loose connector.
Honda Varadero
KTM 690 Enduro R
'90 KDX200
'83 XT500 (never should've sold) :(
MBX50 (the first one!)
 

Offline Sprocketbek

Re: Help Please!
« Reply #5 on: August 01, 2016, 09:51:37 pm »
The spade terminals are either loose where they attach to the coil or one of the wires have broken off at the connector.  Pretty common problem.

Agree with subsequent post too  :thumleft:
KTM often crimp the wires too hard and then the wires are damaged where it enters the connector.
KTM 990 Adv
KTM 640 Adv
 

Offline BIKER

  • Member
  • **
  • Bike: KTM 690 Adventure
    Location: Western Cape
  • Posts: 61
Re: Help Please!
« Reply #6 on: August 03, 2016, 10:08:13 am »
 :thumleft:All sorted !!Broken wire
 

Offline Sprocketbek

Re: Help Please!
« Reply #7 on: August 03, 2016, 10:44:15 am »
Good to hear!

Just randomly, or at a connector?
KTM 990 Adv
KTM 640 Adv
 

Offline Blender

Re: Help Please!
« Reply #8 on: August 03, 2016, 11:08:25 am »
:thumleft:All sorted !!Broken wire

 :thumleft:
Honda Varadero
KTM 690 Enduro R
'90 KDX200
'83 XT500 (never should've sold) :(
MBX50 (the first one!)
 

Offline BIKER

  • Member
  • **
  • Bike: KTM 690 Adventure
    Location: Western Cape
  • Posts: 61
Re: Help Please!
« Reply #9 on: August 03, 2016, 02:13:43 pm »
Broke of at the spade connector.
 

Offline Sprocketbek

Re: Help Please!
« Reply #10 on: August 04, 2016, 08:21:34 pm »
Broke of at the spade connector.
My point exactly.
They over-crimp them.
KTM 990 Adv
KTM 640 Adv