Welcome, Guest. Please Login or Register

Author Topic: 690 issue need help  (Read 659 times)

0 Members and 1 Guest are viewing this topic.

Offline geopat

690 issue need help
« on: November 30, 2018, 12:37:51 pm »
Hey guys I'm in Northern nam and I have a bit of a problem I noticed my 2013 690 was losing an bit of power after a hard ride in the sand and I thought it was my air filter getting blocked had a loom and sure enough it was filthy (inside was fine though) made tracks to a garage that had a cleaning kit but on the way she really started struggling made it to town cleaned the filter but shit no change she still refuses to idle and bogs big time if I get on the gas I have cleaned the fuel filter and checked the injector which was making a nice mist also checked for spark which was ok so I'm out of ideas I know there are issues with fuel.pumps but it sounds fine and the injector is spitting nicely has anyone got an idea of what I could try?
 

Offline Dirt Junkie

  • I talk less and ride more than a
  • Senior Member
  • ***
  • Bike: KTM 690 Enduro
    Location: Eastern Cape
  • Posts: 2,258
  • Thanked: 29 times
Re: 690 issue need help
« Reply #1 on: November 30, 2018, 12:45:56 pm »
try running it on the bad fuel map

Something to think about...
When you complain, you make yourself a victim. Leave the situation, change the situation, or accept your it. All else is madness.

KTM 640 adv,  Aprilia RS 250, Yamaha YZ450F, 2014 KTM 690, 2010 KTM 690R, 2011 BMW F800GS, Yamaha XT600E , 2012 KTM 250 SX-F , KTM 400 EXC, Kawasaki  KLR650, Honda 125 estorm, 2012 KTM 300 XCW, 2008 KTM 690
 

Offline geopat

Re: 690 issue need help
« Reply #2 on: November 30, 2018, 12:56:21 pm »
Thanks for the suggestion gave it a try but no joy I'm starting to think the pump.is on the way out and can't keep up the required pressure with the engine running
 

Offline Dirt Junkie

  • I talk less and ride more than a
  • Senior Member
  • ***
  • Bike: KTM 690 Enduro
    Location: Eastern Cape
  • Posts: 2,258
  • Thanked: 29 times
Re: 690 issue need help
« Reply #3 on: November 30, 2018, 01:03:58 pm »
might be, can remove it and try clean the internal fuel pump filter/mesh screen
Something to think about...
When you complain, you make yourself a victim. Leave the situation, change the situation, or accept your it. All else is madness.

KTM 640 adv,  Aprilia RS 250, Yamaha YZ450F, 2014 KTM 690, 2010 KTM 690R, 2011 BMW F800GS, Yamaha XT600E , 2012 KTM 250 SX-F , KTM 400 EXC, Kawasaki  KLR650, Honda 125 estorm, 2012 KTM 300 XCW, 2008 KTM 690
 

Offline Dirt Junkie

  • I talk less and ride more than a
  • Senior Member
  • ***
  • Bike: KTM 690 Enduro
    Location: Eastern Cape
  • Posts: 2,258
  • Thanked: 29 times
Re: 690 issue need help
« Reply #4 on: November 30, 2018, 01:09:39 pm »
Something to think about...
When you complain, you make yourself a victim. Leave the situation, change the situation, or accept your it. All else is madness.

KTM 640 adv,  Aprilia RS 250, Yamaha YZ450F, 2014 KTM 690, 2010 KTM 690R, 2011 BMW F800GS, Yamaha XT600E , 2012 KTM 250 SX-F , KTM 400 EXC, Kawasaki  KLR650, Honda 125 estorm, 2012 KTM 300 XCW, 2008 KTM 690
 

Offline geopat

Re: 690 issue need help
« Reply #5 on: November 30, 2018, 01:44:58 pm »
Yeah I have done that too it's a new screen installed just before this trip

Anyone know the normal resistance value between pos and neg on the fuel pump?
 

Offline Bommelina

Re: 690 issue need help
« Reply #6 on: November 30, 2018, 02:02:28 pm »
Had similar problem

Try recalibrating the throttle sensor. If I recall correctly the sequence (is somewhere on the forum):

With engine cold, ignition on, fully open the throttle slowly and then close it slowly in one continues slow movement. Switch ignition off and then on, start the bike without touching the throttle. Let it stand and idle for about 15 minutes (?). Switch off. Restart.

hh
 

Offline geopat

Re: 690 issue need help
« Reply #7 on: November 30, 2018, 02:53:47 pm »
Thanks bommelina but she won't rev up when I open her up mechanic agrees it's the pump now we are trying to find one or something that will work
 

Offline aka.Goliath

Re: 690 issue need help
« Reply #8 on: November 30, 2018, 04:56:55 pm »
I agree that it's likely the pump. Had a very similar problem before. Strangely I managed to ride it the next day after filling up again. It definitely was dodgy fuel or possibly even water in the fuel. If you can try drain the tank and fill up with clean fuel and you may do well in flushing the filter or even replacing the inline one, most car filter can work. If it's the pump Bosch has an alternative one which can be used and are much easier and cheaper to get ahold of.
BMW 1150 GSA - 2004
KTM 690R - 2014
KTM 300 X-CW - 2012
KTM 530 EXC Rally - 2011 SOLD, KTM 690R - 2009 SOLD, BMW 1200GS 2009 SOLD
 

Offline geopat

Re: 690 issue need help
« Reply #9 on: November 30, 2018, 07:00:30 pm »
I agree that it's likely the pump. Had a very similar problem before. Strangely I managed to ride it the next day after filling up again. It definitely was dodgy fuel or possibly even water in the fuel. If you can try drain the tank and fill up with clean fuel and you may do well in flushing the filter or even replacing the inline one, most car filter can work. If it's the pump Bosch has an alternative one which can be used and are much easier and cheaper to get ahold of.

Thanks budd I have taken the pump out and the fuel looks good downloaded a lots of checks from advrider so I'll be attacking fresh tomorrow for now I'm having an ice cold windhoek and enjoying a Namibian sunset
 

Offline geopat

Re: 690 issue need help
« Reply #10 on: December 02, 2018, 10:26:20 am »
So another day of troubleshooting and still no joy even connected a fuel pump from.a hilux and no change noted so next question does anyone know of any tricks to test a throttle body?
 

Offline Bommelina

Re: 690 issue need help
« Reply #11 on: December 03, 2018, 07:04:19 am »
Have a look at the fuel pump relay. Any loose or corroded wires on the base contacts.
On my bike these wires vibrate loose, causing intermittent connections result in stuffing the fuel pump up. It actually melted the wire insulation at the relay base.
Also check if the voltage regulator is working properly. Giving out a higher voltage (18 to 24 volt)

hh
 

Offline geopat

Re: 690 issue need help
« Reply #12 on: December 03, 2018, 02:18:52 pm »
Will check that relay today also going to.remove the battery box and check the loume going into the ecu and relays today I cut into the wires and checked voltage on tps and accelerator sensor but within spec but when I open the throttle the butterfly doesn't open it just twitches tried disconnecting the stepper allowing the butterfly to be operated by the cables but the ecu picked up the fault and shuts it down

If ANYONE has any ideas no matter how bizarre please let me know things are getting desperate and it's a 2000km trip home from here
 

Offline Bommelina

Re: 690 issue need help
« Reply #13 on: December 03, 2018, 02:29:40 pm »
Switch the ignition on while looking at the EFI lamp (?) This lamp will flash the problem code (series of long & short morse code signals) This will maybe tell you the problem. The codes are in the little manual. Hope you are having it with the bike.

hh
 

Offline Amsterdam

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 1,340
  • Thanked: 97 times
Re: 690 issue need help
« Reply #14 on: December 03, 2018, 02:33:19 pm »
Have you checked the little fuel filter that sits in the quick connect coupling between the tank and the injector?  According to the part fiche the 2013 does not have this but if yours has some kind of modification maybe it does.

Item 11 - https://sparepartsfinder.ktm.com/ComponentGroupTemplate/Index/14812?modelidentifier=1000091783&isEngine=False

I know that @GJ is in Windhoek at the moment and about to return to Cape Town with a trailer.  Maybe he can help you get your bike home?

@WildWood

KTM 500 XCW, Husqvarna 701, KTM 1190 Adventure
 

Offline geopat

Re: 690 issue need help
« Reply #15 on: December 04, 2018, 06:10:33 am »
Thanks.to.everyone that contributed here my baby is.sorted and back on the road turns out.it.was the.injector after all we had tested that on day 1 and it.looked fine with a decent spray pattern however there was a bit of.shit in there slowing the.rate fuel could come out so.she.would.start.but.not run yesterday I did the injector flip tric,  blew her backwards and boom my baby is.back in action feel like a sucker for getting caught out by such a simple known issue but guess that's how we learn
 

Offline Dirt Junkie

  • I talk less and ride more than a
  • Senior Member
  • ***
  • Bike: KTM 690 Enduro
    Location: Eastern Cape
  • Posts: 2,258
  • Thanked: 29 times
Re: 690 issue need help
« Reply #16 on: December 04, 2018, 07:35:35 am »
Good to hear you are sorted :thumleft:
Something to think about...
When you complain, you make yourself a victim. Leave the situation, change the situation, or accept your it. All else is madness.

KTM 640 adv,  Aprilia RS 250, Yamaha YZ450F, 2014 KTM 690, 2010 KTM 690R, 2011 BMW F800GS, Yamaha XT600E , 2012 KTM 250 SX-F , KTM 400 EXC, Kawasaki  KLR650, Honda 125 estorm, 2012 KTM 300 XCW, 2008 KTM 690
 

Offline Xchallenge

  • Jou Ma is 'n...
  • Forum Whore
  • ****
  • Bike: AJS (all models)
    Location: Gauteng
  • Posts: 7,745
  • Thanked: 42 times
  • Braaap!
Re: 690 issue need help
« Reply #17 on: August 22, 2019, 10:13:40 am »
Hey bud. I know this is a long shot, but can anyone confirm if the BOSCH alternative to the KTM/Husky Fuel Part number is easy to find, and what part number do I quote when looking for the BOSCH alternative?

Is it cheaper than the one from Fuel Performance which is R1600?

My Husky 701 fuel pump is on its way out and Im having intermittent issues of it starting the one day, and not the next, and loses pressure when the bike runs at operating temperature. From Husky mechanics themselves, they claim they replace many of these quite often.

Thanks

I agree that it's likely the pump. Had a very similar problem before. Strangely I managed to ride it the next day after filling up again. It definitely was dodgy fuel or possibly even water in the fuel. If you can try drain the tank and fill up with clean fuel and you may do well in flushing the filter or even replacing the inline one, most car filter can work. If it's the pump Bosch has an alternative one which can be used and are much easier and cheaper to get ahold of.
If you had a psychic midget who killed someone, you would have a small medium at large.
 

Offline aka.Goliath

Re: 690 issue need help
« Reply #18 on: August 22, 2019, 01:36:08 pm »
Hey bud. I know this is a long shot, but can anyone confirm if the BOSCH alternative to the KTM/Husky Fuel Part number is easy to find, and what part number do I quote when looking for the BOSCH alternative?

Is it cheaper than the one from Fuel Performance which is R1600?

My Husky 701 fuel pump is on its way out and Im having intermittent issues of it starting the one day, and not the next, and loses pressure when the bike runs at operating temperature. From Husky mechanics themselves, they claim they replace many of these quite often.

Thanks

I agree that it's likely the pump. Had a very similar problem before. Strangely I managed to ride it the next day after filling up again. It definitely was dodgy fuel or possibly even water in the fuel. If you can try drain the tank and fill up with clean fuel and you may do well in flushing the filter or even replacing the inline one, most car filter can work. If it's the pump Bosch has an alternative one which can be used and are much easier and cheaper to get ahold of.

The replacement was about half the price from Midas (they have to order it in) Its not an exact fit but definitely can work. I'll have to go on the weekend to have a look at the packaging to see the model number - I never actually fitted but had it as a spare rather. There's a thread somewhere on one of the forums about installing it.
BMW 1150 GSA - 2004
KTM 690R - 2014
KTM 300 X-CW - 2012
KTM 530 EXC Rally - 2011 SOLD, KTM 690R - 2009 SOLD, BMW 1200GS 2009 SOLD
 

Offline Xchallenge

  • Jou Ma is 'n...
  • Forum Whore
  • ****
  • Bike: AJS (all models)
    Location: Gauteng
  • Posts: 7,745
  • Thanked: 42 times
  • Braaap!
Re: 690 issue need help
« Reply #19 on: August 22, 2019, 02:22:44 pm »
If you could that would be amazing man.

This is the cheapest I am able to find one for at the moment, but if you reckon the BOSCH could work and is cheaper than this, then I would like to explore that option
https://www.fuelperformance.co.za/index.php?route=product/product&product_id=4118&search=75007088211

When you say it is not an exact fit, what sort of modification would I need to do, and is it worth the effort?
Thanks again for your help, the OEM KTM/Husky Fuel Pump part number is: 75007088211

Hey bud. I know this is a long shot, but can anyone confirm if the BOSCH alternative to the KTM/Husky Fuel Part number is easy to find, and what part number do I quote when looking for the BOSCH alternative?

Is it cheaper than the one from Fuel Performance which is R1600?

My Husky 701 fuel pump is on its way out and Im having intermittent issues of it starting the one day, and not the next, and loses pressure when the bike runs at operating temperature. From Husky mechanics themselves, they claim they replace many of these quite often.

Thanks

I agree that it's likely the pump. Had a very similar problem before. Strangely I managed to ride it the next day after filling up again. It definitely was dodgy fuel or possibly even water in the fuel. If you can try drain the tank and fill up with clean fuel and you may do well in flushing the filter or even replacing the inline one, most car filter can work. If it's the pump Bosch has an alternative one which can be used and are much easier and cheaper to get ahold of.

The replacement was about half the price from Midas (they have to order it in) Its not an exact fit but definitely can work. I'll have to go on the weekend to have a look at the packaging to see the model number - I never actually fitted but had it as a spare rather. There's a thread somewhere on one of the forums about installing it.
If you had a psychic midget who killed someone, you would have a small medium at large.