Welcome, Guest. Please Login or Register

Author Topic: R1200GSA LC Spotlight failure. Fixed  (Read 490 times)

0 Members and 1 Guest are viewing this topic.

Offline JABO

  • Senior Member
  • ***
  • Bike: BMW R1200GS Adventure
    Location: Gauteng
  • Posts: 864
  • Thanked: 12 times
  • Centurion
R1200GSA LC Spotlight failure. Fixed
« on: February 12, 2019, 09:27:15 pm »
Last week my right side Spotlight decided to go the Eskom route and went on permanent load shedding.

Get a quote from BMW. R2300.00 for one.

So I decided while I am gonna fork out the above amount for the Spotlight I can just as well take it apart and see what makes it tick.

Take the whole thing apart to find that the actual light is a sealed unit.

I notched some water build up insure the unit and decided to drill 3 x 4mm holes equally spaced on the side of the lense.
Left out in the sun for 2 days and plugged it in again.

Boom. Working again.

Sealed the holes of with Pratley clear and assembled.

Maybe someone will get the same issue in future.
The above method may just also save you a few RRRRRR's

Sent from my SM-G965F using Tapatalk

Freedom is when you get to a T-junction and think to yourself.
AAAAAAAAAAAAGH I think I'll go left.

www.riot-gear.co.za
 
The following users thanked this post: Tr0jan, zebra - Flying Brick, dustlover, Dustbin Dog

Offline 8 min Mark

Re: R1200GSA LC Spotlight failure. Fixed
« Reply #1 on: February 12, 2019, 10:02:32 pm »
Well done with the repair


Sent from my iPhone using Tapatalk
Makes no difference to me what you ride, as long as you ride!
 

Offline Mikie

  • Kyalami - Jozi
  • Senior Member
  • ***
  • Bike: BMW R1200GS Adventure
    Location: Gauteng
  • Posts: 4,984
  • Thanked: 105 times
Re: R1200GSA LC Spotlight failure. Fixed
« Reply #2 on: February 13, 2019, 08:51:36 am »
Fokken slim, next time, take photies
:paw:

Pronounciation:
M-aai-kie
My-Key
 

Offline Draadwerk

  • Moderator
  • Forum Whore
  • ****
  • Bike: BMW R1200GS Adventure
    Location: Mpumalanga
  • Posts: 7,928
  • Thanked: 39 times
  • My job? Just something I do between rides....
Re: R1200GSA LC Spotlight failure. Fixed
« Reply #3 on: February 13, 2019, 08:54:42 am »
My bike was just a week old when I drove through heavy rain. R spot also stopped working. They replaced it under warranty. 

But, I did a search on overseas forums at that time also...seems this was a known problem and strangely enough always just the right side one. Don't ask me how that makes sense...
 

Offline 8 min Mark

Re: R1200GSA LC Spotlight failure. Fixed
« Reply #4 on: February 13, 2019, 10:44:36 am »
I had it happen a couple of times to my left spot light
I just removed the power supply to the spot and sprayed a moisture displacing spray and it seems not to have faltered in over two years.


Sent from my iPhone using Tapatalk
Makes no difference to me what you ride, as long as you ride!
 

Offline Far@way

  • Newbie
  • *
  • Bike: BMW R1200GS Adventure
    Location: Gauteng
  • Posts: 18
Re: R1200GSA LC Spotlight failure. Fixed
« Reply #5 on: February 19, 2019, 10:26:43 am »
Hi, it seems to me to be specific to the new LED spots on the LC's?
I had a 2009 AC model with the older type bulb spots on and it never gave any issues.
Then I got myself an 2015 LC with the newer LED's and every time I wash the bike the left spot stops working?
I don't use a pressure washer or anything...
I just leave it for a day or 2 then it most probably dries out and then it works again...
No worries...
 

Offline Nish

Re: R1200GSA LC Spotlight failure. Fixed
« Reply #6 on: February 19, 2019, 01:53:26 pm »
Same issue with my RH spot. Apparently the plug collects water when on the side stand. Vaseline and she was working again - no more issues for the last 3 years !
4 wheels move the body
2 wheels move the soul..
 

Offline Far@way

  • Newbie
  • *
  • Bike: BMW R1200GS Adventure
    Location: Gauteng
  • Posts: 18
Re: R1200GSA LC Spotlight failure. Fixed
« Reply #7 on: April 09, 2019, 01:48:17 pm »
I had it happen a couple of times to my left spot light
I just removed the power supply to the spot and sprayed a moisture displacing spray and it seems not to have faltered in over two years.


Sent from my iPhone using Tapatalk

Hi, I know this is a bit old now...but I washed my bike again today and now the spot does not work.
I'm about to do the little trick of unplugging the wire and treating it with water repellent...but I battle to unplug the the wire?
I don't want to use force but it does not want to budge....
How did you do it?
No worries...
 

Offline JABO

  • Senior Member
  • ***
  • Bike: BMW R1200GS Adventure
    Location: Gauteng
  • Posts: 864
  • Thanked: 12 times
  • Centurion
Re: R1200GSA LC Spotlight failure. Fixed
« Reply #8 on: April 09, 2019, 02:09:43 pm »
It is held in with a clip mechanism.
You have to wedge a small flat tip screwdriver in there from the hole in the front bottom to release it.

www.riot-gear.co.za

Freedom is when you get to a T-junction and think to yourself.
AAAAAAAAAAAAGH I think I'll go left.

www.riot-gear.co.za
 
The following users thanked this post: Far@way

Offline Far@way

  • Newbie
  • *
  • Bike: BMW R1200GS Adventure
    Location: Gauteng
  • Posts: 18
Re: R1200GSA LC Spotlight failure. Fixed
« Reply #9 on: April 11, 2019, 02:54:32 pm »
It is held in with a clip mechanism.
You have to wedge a small flat tip screwdriver in there from the hole in the front bottom to release it.

www.riot-gear.co.za
Awesome! Thank you so much, I managed to unplug them.
No worries...