Welcome, Guest. Please Login or Register

Author Topic: Help needed - Eratic idling on 1200 GS  (Read 262 times)

0 Members and 1 Guest are viewing this topic.

Offline WF

  • Pack Dog
  • **
  • Bike: BMW R1200GS Adventure
    Location: Gauteng
  • Posts: 64
Help needed - Eratic idling on 1200 GS
« on: June 20, 2009, 06:40:27 pm »
Hi WD;S
Got a 2007 1200GS, 30000KM'S.Been serviced regularly. When starting up it wont idle and dies. When you then try start her up it sounds exactly like a flat battery.You battle a bit to start and then it wont idle. If you keep up the revs for a while and get her nice and warm the problem goes away, idles no problem. For the rest of the day no hassel but once cold again, same thing.
Ive changed and then replaced with a new battery, makes no difference ??
Everyone dies, not everyone lives !
 

Offline Swanniebraai

  • Grey hound
  • ****
  • Bike: BMW R1150GS
    Location: Western Cape
  • Posts: 5,380
  • Thanked: 10 times
  • BLESSED!!
    • SwannieBraai WORSBRAAI
Re: Help needed - Eratic idling on 1200 GS
« Reply #1 on: June 20, 2009, 06:48:14 pm »
Hope not its your fuel pump, mine did same but then didnt want to start at all.
Lets hope for somethin small  rather!  :thumleft:
May the WORS be WITH you!
 

Offline Beemer Man (RIP)

  • Race Dog
  • ***
  • Bike: BMW R1200GS
    Location: Gauteng
  • Posts: 2,408
Re: Help needed - Eratic idling on 1200 GS
« Reply #2 on: June 20, 2009, 08:36:52 pm »
D I thought about this a lot after you phoned me, It could well be the bodies where the idle screws go into the throttle bodies are dirty,   I had an 1150 here the other day which also did not idle well, when I pulled out the idle screws the muck sitting at the bottom was amazing, cleaned out with a carb cleaner and it went away, also could be throttle bodies are out of sink.
I think if I actually found My mind, I probably wouldn't know what to do with it,