Welcome, Guest. Please Login or Register

Author Topic: 690 Not starting help! UPDATE  (Read 1325 times)

0 Members and 1 Guest are viewing this topic.

Offline husky

  • Senior Member
  • ***
  • Bike: KTM 640 Adventure
    Location: Kwazulu Natal
  • Posts: 729
  • Thanked: 11 times
Re: 690 Not starting help!
« Reply #20 on: November 15, 2011, 01:28:30 pm »
No solution I'm afraid but the electronic gremlins appear to be tbe 690's downfall. Check out AdvRider for some proper frights including the guy that battled through Africa (FishFund), including changing the wiring harness etc, as I recollect. Still problems. RallyRaid UK were very helpful.

To be fair the BM 800 with him also gave a bit of trouble.

I often ride alone so this is mainly what scares me about the 690, otherwise I'd be borrowing money for one.
 

terminator1

  • Guest
Re: 690 Not starting help!
« Reply #21 on: November 15, 2011, 01:34:47 pm »
Hi mate

I never had any problems with that bike, except for in water. It seems to have been solved with a bit of Q20. Ask the guys at KTM capetown - they mentioned a similar problem with one of their bikes, and I think found the solution/.
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help!
« Reply #22 on: November 15, 2011, 01:54:25 pm »
It is at Alfies' workshop now, so lets see what they say!
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help! UPDATE
« Reply #23 on: November 17, 2011, 07:01:21 am »
UPDATE- for those of you you might one day have or had this issue, it still remains unresloved.
Tue Alfies mach Rob called to say he replaced two petrol filters, one in the tank cost R650,00 and one in the petrol pump???? Bike started he rode it around was 100% did the TPS reset hooked up to PC no faults all good, come fetch.-- I get to AC yesterday , the bike wont start again, AC, Rod Gray etc all come out sctratching heads no idea what the problem is. Alfie is going to try get a TPS from a mates 690 and fit it to mine to see what happens, so we wait and hold thumbs, bill sitting at about R1500 so far.
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

terminator1

  • Guest
Re: 690 Not starting help! UPDATE
« Reply #24 on: November 17, 2011, 07:02:36 am »
UPDATE- for those of you you might one day have or had this issue, it still remains unresloved.
Tue Alfies mach Rob called to say he replaced two petrol filters, one in the tank cost R650,00 and one in the petrol pump???? Bike started he rode it around was 100% did the TPS reset hooked up to PC no faults all good, come fetch.-- I get to AC yesterday , the bike wont start again, AC, Rod Gray etc all come out sctratching heads no idea what the problem is. Alfie is going to try get a TPS from a mates 690 and fit it to mine to see what happens, so we wait and hold thumbs, bill sitting at about R1500 so far.


checked the sparkie?  :peepwall:
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help! UPDATE
« Reply #25 on: November 17, 2011, 07:04:58 am »
UPDATE- for those of you you might one day have or had this issue, it still remains unresloved.
Tue Alfies mach Rob called to say he replaced two petrol filters, one in the tank cost R650,00 and

checked the sparkie?  :peepwall:
I asked Alfie about that, he says the PC they connected would have told him if the plug was not working??
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

terminator1

  • Guest
Re: 690 Not starting help! UPDATE
« Reply #26 on: November 17, 2011, 07:06:34 am »
UPDATE- for those of you you might one day have or had this issue, it still remains unresloved.
Tue Alfies mach Rob called to say he replaced two petrol filters, one in the tank cost R650,00 and

checked the sparkie?  :peepwall:
I asked Alfie about that, he says the PC they connected would have told him if the plug was not working??

not too sure about that! I once had a similar problem, and replaced the sparkie - hey presto. I think those bikes run at high speeds and temp and chow plugs. I'll bet you could have saved the R1500  :pot:
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help! UPDATE
« Reply #27 on: November 17, 2011, 07:12:56 am »
UPDATE- for those of you you might one day have or had this issue, it still remains unresloved.
Tue Alfies mach Rob called to say he replaced two petrol filters, one in the tank cost R650,00 and

No ways i took that filter out, it had completely collapsed and was black with dirt, so that was due to be replced, he asked me it it was in the 1st plug was not sure, have you relpaced the plug before?
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

terminator1

  • Guest
Re: 690 Not starting help! UPDATE
« Reply #28 on: November 17, 2011, 07:17:15 am »
UPDATE- for those of you you might one day have or had this issue, it still remains unresloved.
Tue Alfies mach Rob called to say he replaced two petrol filters, one in the tank cost R650,00 and

No ways i took that filter out, it had completely collapsed and was black with dirt, so that was due to be replced, he asked me it it was in the 1st plug was not sure, have you relpaced the plug before?

yes have replaced. that fixed the problem right away. the bike was also serviced more than required at automotorcycles in PE. If the filters were fouled, then they have something to answer for  :patch:
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help! UPDATE
« Reply #29 on: November 17, 2011, 07:35:14 am »
UPDATE- for those of you you might one day have or had this issue, it still remains unresloved.
Tue Alfies mach Rob called to say he replaced two petrol filters, one in the tank cost R650,00 and

Intrsting,i persnally took the filter out the tank,  and Bushcat cut it open with a Hack saw, it was finished the filter paper was black and had collapsed, anyway , wil get it sorted, wil call AC now and ask then to check the plug.
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

terminator1

  • Guest
Re: 690 Not starting help! UPDATE
« Reply #30 on: November 17, 2011, 07:39:01 am »
just replace the plug anyway. remember to use the special high temp/performance plug.

how many k's have you done on the bike since you got it, and what sort of terrain? did you perhaps use shitty fuel, or put diesel in the tank? serious Q. Did one of the pump jockey's do it when you weren't watching, and realised his mistake, filled the rest with petrol  and didn't tellu?

anythings possible in SA  :deal:
« Last Edit: November 17, 2011, 07:39:26 am by J-dog™ »
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help! UPDATE
« Reply #31 on: November 17, 2011, 07:41:51 am »
just replace the plug anyway. remember to use the special high temp/performance plug.

Not many km think it is one 7600km now, i put my own juice, in, i buy 20 lt and keep at home, unless i am out in the sticks, but that has not happened, do mostly slow tech ridding.
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

Offline Frohan Visser

  • Senior Member
  • ***
  • Bike: NER-A-CAR
    Location: Western Cape
  • Posts: 616
Re: 690 Not starting help! UPDATE
« Reply #32 on: November 17, 2011, 08:11:42 am »
777 and J-dog, Im following this thread and I know KTM Cape Town had a hell of a lot of shit with their 690 demo , it was even sent up to the Joburg KTM guys to try and sort it out, eventually someone decided to put a new spark plug in, and everything was 100% again.
1986 Suzuki DR 600, Confiscated in Egypt
1992 Suzuki DR 800, sold
1997 Suzuki DR 650, sold
2005 KTM 640 Adv, sold
201.. KTM 690 R in the next 2 years
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help! UPDATE
« Reply #33 on: November 17, 2011, 08:30:56 am »
Spoke to Rod Gray now going to change the plug later and see what happens
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

terminator1

  • Guest
Re: 690 Not starting help! UPDATE
« Reply #34 on: November 17, 2011, 08:32:35 am »
777 and J-dog, Im following this thread and I know KTM Cape Town had a hell of a lot of shit with their 690 demo , it was even sent up to the Joburg KTM guys to try and sort it out, eventually someone decided to put a new spark plug in, and everything was 100% again.


LOL so we're on the right track. Often the simplest solutions work. The 690 plugs don't last very long due to the high perfortmance motor. Change them often and always carry a spare  :thumleft:
 

Offline Frohan Visser

  • Senior Member
  • ***
  • Bike: NER-A-CAR
    Location: Western Cape
  • Posts: 616
Re: 690 Not starting help! UPDATE
« Reply #35 on: November 17, 2011, 08:36:00 am »
Cool, let us know ............... :thumleft:
1986 Suzuki DR 600, Confiscated in Egypt
1992 Suzuki DR 800, sold
1997 Suzuki DR 650, sold
2005 KTM 640 Adv, sold
201.. KTM 690 R in the next 2 years
 

Offline 777

  • Senior Member
  • ***
  • Bike: BMW F800GS
    Location: Kwazulu Natal
  • Posts: 2,457
  • Thanked: 4 times
Re: 690 Not starting help! UPDATE
« Reply #36 on: November 17, 2011, 10:38:32 am »
AC just called me to say they found the problem, apprently the spark plug cap was not sealing correctly water , was getting in and the spark plug was arcing on the engine, had to replace plug and cap,- say it now  , all at once "TOLD YOU SO"

I just hope they are right now, but sounds like the problem , if i recall it happned after each wash, now that i think of it!!!!!
TS 50- Gave away
RM 125- Not sure where it is.
IT 200- Sold.
XT 550- Sold.
CR 250-Sold. RMX 250-Sold WR 250-Sold. CFR 450x-Sold. CRF 250x-Sold. XT 660R- Sold KTM 690 Enduro- Alfie Cox Special Edition .Honda XR 650L., WR450, Current bikes, KTM 500 Six Days and BMW 800GS
 

Offline africanSky

Re: 690 Not starting help! UPDATE
« Reply #37 on: November 17, 2011, 10:46:38 am »
The coil and plug really seem to be the achilles heel of these bikes - at least it is easy to fix once you know. Thankfully have not had this issue with mine, but good to know and check first.

Glad its sorted! :thumleft:

 

terminator1

  • Guest
Re: 690 Not starting help! UPDATE
« Reply #38 on: November 17, 2011, 10:47:47 am »
AC just called me to say they found the problem, apprently the spark plug cap was not sealing correctly water , was getting in and the spark plug was arcing on the engine, had to replace plug and cap,- say it now  , all at once "TOLD YOU SO"

I just hope they are right now, but sounds like the problem , if i recall it happned after each wash, now that i think of it!!!!!

he he ....

I TOLD YOU SO!!!
 

Offline Rough Rider

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 4,854
  • Thanked: 37 times
  • Hang time
Re: 690 Not starting help! UPDATE
« Reply #39 on: November 17, 2011, 10:48:04 am »
I eventually sold my 690 due to all the electronic kak which no one seemed to be able to sort out  ???
« Last Edit: November 17, 2011, 10:48:44 am by Rough Rider »
Current rides: 2015 WR250F / 2016 690R / 2017 701SM