Welcome, Guest. Please Login or Register

Author Topic: 690 Not starting help! UPDATE  (Read 1279 times)

0 Members and 1 Guest are viewing this topic.

Offline Frohan Visser

  • Senior Member
  • ***
  • Bike: NER-A-CAR
    Location: Western Cape
  • Posts: 616
Re: 690 Not starting help! UPDATE
« Reply #40 on: November 17, 2011, 10:55:24 am »
AC just called me to say they found the problem, apprently the spark plug cap was not sealing correctly water , was getting in and the spark plug was arcing on the engine, had to replace plug and cap,- say it now  , all at once "TOLD YOU SO"

I just hope they are right now, but sounds like the problem , if i recall it happned after each wash, now that i think of it!!!!!

Glad its sorted.. :thumleft:
1986 Suzuki DR 600, Confiscated in Egypt
1992 Suzuki DR 800, sold
1997 Suzuki DR 650, sold
2005 KTM 640 Adv, sold
201.. KTM 690 R in the next 2 years
 

Offline Pistonpete

  • Shop Mods
  • Bachelor Dog
  • *
  • Bike: KTM 990 Adventure
    Location: Western Cape
  • Posts: 17,849
  • Thanked: 75 times
  • Live to Ride...Ride to Live
Re: 690 Not starting help! UPDATE
« Reply #41 on: November 17, 2011, 11:33:48 am »
777 and J-dog, Im following this thread and I know KTM Cape Town had a hell of a lot of shit with their 690 demo , it was even sent up to the Joburg KTM guys to try and sort it out, eventually someone decided to put a new spark plug in, and everything was 100% again.

lol....incredible but it happens
'Routine is the thief of time'