Welcome, Guest. Please Login or Register

Author Topic: KTM 690 SM - Helping out a friend  (Read 3088 times)

0 Members and 1 Guest are viewing this topic.

Offline ChrisL - DUSTRIDERS

  • Forum Vendor
  • Castrated Dog
  • ******
  • Bike: BMW R1200GS
    Location: Western Cape
  • Posts: 28,794
  • Thanked: 413 times
    • dustriders.co.za
Re: KTM 690 SM - Helping out a friend
« Reply #100 on: October 16, 2019, 01:07:24 pm »
 1150

Dis daai goeie vibes wat die bike nou laat beter loop!! :deal: ;) :lol8:
Hyt seker nou n gawe bottom torque ook. ;)
Hoop vir jou part hy is nou gesort.
MOTORCYCLE ACCESSORIES RETAILER
info@dustriders.co.za
ENDURISTAN SOFTLUGGAGE IMPORTER
www.dustriders.co.za
 

Offline BullFrog

  • Senior Member
  • ***
  • Bike: Honda XR650L
    Location: Gauteng
  • Posts: 797
  • Thanked: 38 times
  • Previously Naartjie
Re: KTM 690 SM - Helping out a friend
« Reply #101 on: October 16, 2019, 02:46:38 pm »
'Archangel' is die regte naam vir jou, want ons 'mere mortals' het nie die geduld vir wat jy vermag het nie!

Goeie werk!!
'70 Triumph Bonneville 650 T120, '84 Honda VF 1000 RE, '01 Yamaha YZ 250 N, '12 Honda XR 650 L, '14 Honda NC 750 X

If I REALLY wanted to ride a BMW, I would join the Tshwane Metro.
 

Offline funky_munky

Re: KTM 690 SM - Helping out a friend
« Reply #102 on: October 16, 2019, 03:18:50 pm »
I had a 690 SM, was a seriously awesome bike to ride. lots of fun. It is probably the bike which I miss selling the most...
Africa Twin CRF1000 and KTM 690 - Aaaah yeah, perfect combo....
 

Offline Rough Rider

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 4,899
  • Thanked: 41 times
  • Hang time
Re: KTM 690 SM - Helping out a friend
« Reply #103 on: October 17, 2019, 07:44:41 am »
After charging overnight, it swung and started once or twice for a couple of seconds, but couldn't get it to run/idle. Then the battery went dead with all the attempts to start. Back on the charger for now, but think we'll get life out of it tonight.  :thumleft:

You need a new battery, it sounds like that one has died.

Dude!!!!
Current rides: 2015 WR250F / 2016 690R / 2017 701SM
 
The following users thanked this post: Archangel

Offline Archangel

  • Admin & Commercial
  • Senior Member
  • ***
  • Bike: AJS (all models)
    Location: Western Cape
  • Posts: 3,874
  • Thanked: 48 times
  • Of maar net Gabriel
Re: KTM 690 SM - Helping out a friend
« Reply #104 on: October 17, 2019, 10:50:58 am »
After charging overnight, it swung and started once or twice for a couple of seconds, but couldn't get it to run/idle. Then the battery went dead with all the attempts to start. Back on the charger for now, but think we'll get life out of it tonight.  :thumleft:

You need a new battery, it sounds like that one has died.

Dude!!!!

The battery was not the primary issue, but it became an issue due to not riding the bike. But yeah, well spotted. You called it.  :thumleft:

Offline Archangel

  • Admin & Commercial
  • Senior Member
  • ***
  • Bike: AJS (all models)
    Location: Western Cape
  • Posts: 3,874
  • Thanked: 48 times
  • Of maar net Gabriel
Re: KTM 690 SM - Helping out a friend
« Reply #105 on: October 17, 2019, 11:06:42 am »
So to summarize here is what was done and what I think sorted the issue:

Cleaned injectors - no impact
New throttle body - no impact
Valve clearances - no impact
Bypassed sidestand killswitch - no impact
Bypassed roll over sensor - no impact
Removed SAS pipes and sensors (were disconnected anyways) - no impact
New EPT module - no impact
New EFI module - no impact
Changed pipes - no impact
Removed various dodgy wiring connections - no impact
Accelerator module - no impact  (Btw, big thanks to Roodt for lending me one to check if it solves my issue  :thumleft:  )

I may have missed some, so I'll update this if I remember something.

What I think actually solved the issue:
New map with disabled SAS & O2

Note: I don't know if just the new map or disabling the SAS or O2 separately would have sorted the problem. I didn't change them one by one, so it could be any one of the three or the combination.

Offline Rough Rider

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 4,899
  • Thanked: 41 times
  • Hang time
Re: KTM 690 SM - Helping out a friend
« Reply #106 on: October 17, 2019, 01:54:13 pm »
After charging overnight, it swung and started once or twice for a couple of seconds, but couldn't get it to run/idle. Then the battery went dead with all the attempts to start. Back on the charger for now, but think we'll get life out of it tonight.  :thumleft:

You need a new battery, it sounds like that one has died.

Dude!!!!

The battery was not the primary issue, but it became an issue due to not riding the bike. But yeah, well spotted. You called it.  :thumleft:

I had a problem on my 690 recently where the clock kept resetting itself to noon every time I switched off the ignition; no other issues. It also turned out to be a dodge battery.
Current rides: 2015 WR250F / 2016 690R / 2017 701SM
 

Offline Archangel

  • Admin & Commercial
  • Senior Member
  • ***
  • Bike: AJS (all models)
    Location: Western Cape
  • Posts: 3,874
  • Thanked: 48 times
  • Of maar net Gabriel
Re: KTM 690 SM - Helping out a friend
« Reply #107 on: October 27, 2019, 08:53:44 pm »
After two days of riding (120km), the issue returned...

Some screenshots of the error codes.



Sent from my VTR-L29 using Tapatalk

« Last Edit: October 28, 2019, 12:57:40 pm by Archangel »
 

Online geopat

Re: KTM 690 SM - Helping out a friend
« Reply #108 on: October 27, 2019, 09:23:45 pm »
holy crap thats alot of faults stupid question after all this time but has the wiring loume not worn through under the battery box?
 

Offline Mpandla

Re: KTM 690 SM - Helping out a friend
« Reply #109 on: October 28, 2019, 06:43:59 am »
holy crap thats alot of faults stupid question after all this time but has the wiring loume not worn through under the battery box?

I also think there is a short or earthing problem somewhere. Those looks like complete random errors
KTM 690
Mpandla - The bald one
 

Offline Archangel

  • Admin & Commercial
  • Senior Member
  • ***
  • Bike: AJS (all models)
    Location: Western Cape
  • Posts: 3,874
  • Thanked: 48 times
  • Of maar net Gabriel
Re: KTM 690 SM - Helping out a friend
« Reply #110 on: October 28, 2019, 09:12:14 am »
I definitely think there is some overall system error, like voltage regulator, earth fault, or whatever that causes these symptoms.

Last night after running for a while trying to figure out the issue, it didn't want to start at all and didn't show any faults.

When I actually get it running while in this error state, a throttle blip always results in a big backfire or popping.

This morning she started and then idled smoothly with no popping or backfire on the throttle blip.

Still no new error messages after clearing them last night (shown above).

Sent from my VTR-L29 using Tapatalk


Offline Rough Rider

  • Senior Member
  • ***
  • Bike: Husqvarna (all models)
    Location: Western Cape
  • Posts: 4,899
  • Thanked: 41 times
  • Hang time
Re: KTM 690 SM - Helping out a friend
« Reply #111 on: October 28, 2019, 12:23:51 pm »
I owned one of these,I bought it when it was a year old like new with low mileage, and it had stalling issues right from the beginning although, nothing like what you are experiencing. I also tried everything known to man to resolve the issue and never did. In the end I came to the conclusion that it was a factory problem and there was no cure, and sold the bike. 
Current rides: 2015 WR250F / 2016 690R / 2017 701SM
 

Offline Archangel

  • Admin & Commercial
  • Senior Member
  • ***
  • Bike: AJS (all models)
    Location: Western Cape
  • Posts: 3,874
  • Thanked: 48 times
  • Of maar net Gabriel